Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 20, 2024 - 05:00 UTC
Scheduled
Dear customer,
Please note MPO will be releasing a new version (v6.6.0) with features and improvements on your environment.
What to expect: While we do not anticipate any downtime, there is a slight possibility of brief service interruptions. We will be taking all necessary precautions to minimize any potential impact on your applications or integrations.
Please reach out if you have any questions or concerns.
Best regards, Mambu.
Posted Nov 11, 2024 - 14:08 UTC
This scheduled maintenance affected: MPO (WU MPO Production).